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A. Multiple Choice Questions 
1. Which of the following technique can be used to allow only date value in cell? 
(a) Data formatting (b) Data sorting 
(c) Data filtering (d) Data validation

2. Which of the following options when selected deletes all data validation? 
(a) Delete formatting (b) Delete all 
(c) Delete formula (d) Delete me 

3. We can replace multiple occurrences of a word using which of the following facilities of Calc? 
(a) Find and replace 
(b) By replace only 
(c) By copy command 
(d) By preview command 

4. What is the name of mechanism to arrange the data in a particular order? 
(a) Sorting (b) Searching 
(c) Filtering (d) Validating 

5. What is the name of mechanism to filter out unnecessary data? 
(a) Sorting (b) Searching 
(c) Filtering (d) Validating 

6. Which of the following type of package does Calc refer to? 
(a) Spreadsheet (b) Double sheet 
(c) Multi-sheet (d) Cannot determine 

7. Which of the following is an extension of a worksheet created in Calc? 
(a) .ods (b) .odd 
(c) .xls (d) .obj 

8. How can one calculate the total of values entered in a worksheet column of? 
(a) By manual entry (b) By auto-sum 
(c) By formula (d) By sum function 

9. If we move a cell containing a formula having reference to another cell in the worksheet what will happen to the cell numbers used in the formula? 
(a) The cell row and columns are changed at destination. 
(b) The cell row change at destination. 
(c) The cell columns are changed at destination. 
(d) No change will scour. 

10. What is the correct way to enter a function in Calc? 
(a) Directly typing function name in a cell 
(b) Using function wizard or selecting from toolbar 
(c) Both (a) and (b) 
(d) Depends on the function

11. A function should start with __________________. 
(a) ‘=’ sign (b) alphabets 
(c) numbers (d) All of the these 

12. Which of the following option is used to print a chart? 
(a) Insert → Chart (b) File → View 
(c) File → Print (d) View → Chart 

13. How many axes does charts in Calc have? 
(a) Two (b) Three 
(c) Two or three (d) Four 

14. The chart preview can be seen in________________. 
(a) Page preview (b) Chart preview 
(c) Export chart (d) All of these

B. Fill in the blanks 
1. The column immediately next to column “Z” is AA. 
2. The default extension of a workbook created using a LibreOffice Calc spreadsheet is .ods. 
3. The spreadsheet feature used to continue the series is called as Fill Handle
4. The formula “=MIN(C1:C5)” stored in cell C6 when copied to cell D6 changes to =MIN(D1:D5) 
5. The formula in cell A2 is =B2+C3. On copying this formula to cell C2, C2 will change to C2=D2+E3 
6. The cell address of the cell formed by the intersection of the ninth column and the eighth row will be I8.
7. $A1$B2 is an example of mixed referencing in spreadsheet software. 
8. Numbers entered into a cell are automatically right aligned. 
1. If A1:A5 contain the numbers 16, 10, 3, 25 and 6 then =Average(A1:A5;60) will display 20. 
2. In relative referencing, the reference changes rows and columns automatically when it is copied to a new cell. 


C. State whether the following statements are True or False 
1. A cell is a combination of row and column. True
2. A spreadsheet is also called as worksheet.True
3. There are ‘n’ number of sheets in a spreadsheet. True
4. In a spreadsheet, we can change the column width and row height. True
5. $A1$B2 is an example of mixed referencing. True

D. Solve the following in a spreadsheet 
1. Cell A1 contains the number 10 and B1 contains 5. What will be the contents of cell C1, if the formula =A1+B1*2^3 is entered in cell C1? 
Ans: 50
2.The contents of Cell A1, B1, C1 and D1 are 5, –25, 30 and –35, respectively. What will be the value displayed in cell E1 which contains the formula =MIN(A1:D1).
Ans: -35 

3. Cell D5 contains the formula =$B$5+C5 and this formula is copied to cell E5, what will be the copied formula in cell E5?  Ans: E5=$B$5+D5

4. Cell D5 contains the formula =$B5 + C5 and this formula is copied to cell E5, what will be the copied formula in cell E5? Ans E5=$B5+D5

5. Cell D5 contains the formula =$B5 + C$5 and this formula is copied to cell E6, what will be the copied formula in cell E6? Ans E6=$B6+D5


E. Short answer questions (50 words) 
1. What do you call the document created in a spreadsheet application? 
Ans: Document created in spreadsheet application is called Workbook, workbook is collection of worksheets.
2. What are the steps to create a new spreadsheet? 
Ans: The steps to create the spreadsheet are as mentioned below: 
Step 1: Open the LibreOffice Calc by using the standard process. 
Step 2: Observe that the Calc has created the worksheets automatically. Give the specific name to the worksheet say ‘Stationary Bill’. To do this 
Select the menu Sheet → Rename Sheet. 
Step 3: Enter the data given in the above table in the worksheet.
3. What is the difference between spreadsheet, worksheet and sheet? 
A spreadsheet is a grid which interactively manages and organises data in rows and columns. It is also called as Electronic Spreadsheet.

Sheet menu: contains commands to insert and delete cell, rows and columns, insert sheet, rename sheet, fill cell, etc

Worksheet: The worksheet in Calc is also referred to as spreadsheet. The spreadsheet can have many sheets. Each sheet can have many individual cells arranged in rows and columns. The sheet tab shows its default name as Sheet1, Sheet2, Sheet3, ….
4. What is the default name of the worksheet? How can it be renamed? 

Ans: The sheet tab shows its default name as Sheet1, Sheet2, Sheet3, ….. We can rename it by right click on the Sheet tab and click on rename. Give new name
5. Write the steps to insert and delete the worksheet in Calc. 
On the sheet tab Right click and Insert 
Or
On Insert menu Click on Worksheet
6. What is an active cell? How to delete the contents of an active cell? 
Ans: Active cell: In a spreadsheet, cell is the place where we enter the data. Before entering any data in the cell, it has to be first selected by placing a cursor on it. When we position the mouse cursor on a cell, it gets selected, and is ready to take data from the user. This selected or activated cell is called as active cell. It is always highlighted, with a thick border. The address of the active cell is displayed in the name box.

7. What is relative and absolute cell address in the spreadsheet? 

Referencing is the way to refer the formula or function from one cell to the next cell along the row or column. There are three types of referencing. 
Relative referencing 
Mixed referencing 
Absolute referencing 

(a) Relative Referencing: When the formula is copied from one cell to other it changes with respect to cell where it is being copied is called relative referencing for example If formula C2=A2 +B2 is copied to cell D10 then D10=B10+C10
 (b)Mixed referencing: When the formula is copied from one cell to other it partially changes (either row or column) with respect to cell where it is being copied is called mixed referencing for example If formula C2=$A2 +B$2 is copied to cell D10 then D10=A10+C2
(c) Absolute referencing: When the formula is copied from one cell to other it does not change with respect to cell where it is being copied is called relative referencing for example If formula C2=$A$2 +$B$2 is copied to cell D10 then D10=$A$2 + $B$2

8. Explain any two operations performed on data in a spreadsheet. 

Spreadsheet Software has the most powerful features to calculate numerical data using formulae. As we use a calculator for calculation, Calc can add, subtract, divide, multiply and much more. LibreOffice Calc uses standard operators for formulae, such as a plus(+), minus(-), multiplication (*), a division (/) for arithmetic operation. 
	= 4+5*3 
	= 4+15 
	19 



	=A1*B1-D2 




9. How do formulae work in a spreadsheet? 

Ans: Formulae: Any expressions that begins with an equals ‘=’ is treated as formula. In the expression, the ‘=’ followed by values, cell address and functions are called as formula. When a formula is entered in a cell in a worksheet the value of the equation is displayed in the cell and the formula is shown in the formula bar.
The main advantage of entering formula with cell addresses and operators, works just like a variable. When the values of the cells concerned change, the results obtained by the formula also get updated accordingly.


10. How to make visible the desired toolbar a spreadsheet? 
View menu contains the option  to make visible the desired toolbar in worksheet.

11. Give the syntax and example of any three mathematical functions in spreadsheet. 
ROUND - round the number to the specified number of digits.
ABS - Returns the absolute value of a number
MOD - Returns the remainder from division
POWER - Returns the result of a number raised to a power
SQRT - Returns a positive square root

12. Give the syntax and example of any three statistical functions in spreadsheet. 
The SUM function is the first must-know formula in Excel. It usually aggregates values from a selection of columns or rows from your selected range.
=SUM(number1, [number2], …)
The AVERAGE function should remind you of simple averages of data such as the average number of shareholders in a given shareholding pool.
=AVERAGE(number1, [number2], …)
The COUNT function counts all cells in a given range that contain only numeric values.
=COUNT(value1, [value2], …)
COUNTA counts all cells in a given rage. However, it counts all cells regardless of type. That is, unlike COUNT that only counts numerics, it also counts dates, times, strings, logical values, errors, empty string, or text.
=COUNTA(value1, [value2], …)
The MAX and MIN functions help in finding the maximum number and the minimum number in a range of values.
=MIN(number1, [number2], …)
 
Example:
=MIN(B2:C11) – Finds the minimum number between column B from B2 and column C from C2 to row 11 in both columns B and C.
=MAX(number1, [number2], …)
Example:
=MAX(B2:C11) – Similarly, it finds the maximum number between column B from B2 and column C from C2 to row 11 in both columns B and C.



13. Give the syntax and example of any three decision making functions in spreadsheet. 

The IF function is often used when you want to sort your data according to a given logic. The best part of the IF formula is that you can embed formulas and function in it.
=IF(logical_test, [value_if_true], [value_if_false])
 
Example:
=IF(C2<D3, ‘TRUE,’ ‘FALSE’) – Checks if the value at C3 is less than the value at D3. If the logic is true, let the cell value be TRUE, else, FALSE
  
SUMIF and COUNTIF
Formula: =COUNTIF(D5:D12,”>=21″)
These two advanced formulas are great uses of conditional functions.  SUMIF adds all cells that meet certain criteria, and COUNTIF counts all cells that meet certain criteria. 

14. Give the syntax and example of any three date and time functions in spreadsheet. 
Get current date and time:
· =TODAY()- returns today's date
· =NOW() - returns the current date and time
Retrieve dates in Excel:
· =DAY - returns the day of the month
· Here are a few formula examples:
· =DAY(A2) - returns the day of the date in A2
· =DAY(DATE(2015,1,1)) - returns the day of 1-Jan-2015
· =DAY(TODAY()) - returns the day of today's date
· 
= MONTH() - returns the month of a specified date
For example:
=MONTH(A2) - returns the month of a date in cell A2.
=MONTH(TODAY()) - returns the current month.


· YEAR - returns the year of a specified date
· YEAR(A2) - returns the year of a date in cell A2.
· =YEAR("20-May-2015") - returns the year of the specified date.
· =YEAR(DATE(2015,5,20)) - a more reliable method to get the year of a given date.
· =YEAR(TODAY()) - returns the current year

15. Give the syntax and example of any three logical functions in spreadsheet. 
[bookmark: _GoBack]AND, OR and NOT logical functions  work with the logical values. You use these functions when you want to carry out more than one comparison in your formula or test multiple conditions instead of just one. As well as logical operators, Excel logical functions return either TRUE or FALSE when their arguments are evaluated.
	Function
	Description
	Formula Example
	Formula Description

	AND
	Returns TRUE if all of the arguments evaluate to TRUE.
	=AND(A2>=10, B2<5)
	The formula returns TRUE if a value in cell A2 is greater than or equal to 10, and a value in B2 is less than 5, FALSE otherwise.

	OR
	Returns TRUE if any argument evaluates to TRUE.
	=OR(A2>=10, B2<5)
	The formula returns TRUE if A2 is greater than or equal to 10 or B2 is less than 5, or both conditions are met. If neither of the conditions it met, the formula returns FALSE.

	NOT
	Returns the reversed logical value of its argument. I.e. If the argument is FALSE, then TRUE is returned and vice versa.
	=NOT(A2>=10)
	The formula returns FALSE if a value in cell A1 is greater than or equal to 10; TRUE otherwise.



16. Give the syntax and example of any three string functions in spreadsheet. 

The LEFT function returns the specified number of characters in a text string, starting from the first or left-most character. Use this function to extract a sub-string from the left part of a text string. Syntax: LEFT(text_string, char_numbers).

RIGHT function can be used both as a worksheet function and a VBA function. The RIGHT function returns the specified number of characters in a text string, starting from the last or right-most character. Use this function to extract a sub-string from the right part of a text string. Syntax: RIGHT(text_string, char_numbers). It is necessary to mention 

 The worksheet LEN function returns the number of characters in a text string. Use this function to get the length of a text string. Syntax: LEN(text_string
). 
the text_string argument which is the text string from which you want to extract the specified number of characters.

17. Explain the advantages of drawing a chart in Calc. 
Ans:It is not easy to comprehend, compare, analyse or present data when they are represented as numbers. But when data are presented in the form of charts they become an effective tool to communicate
18. Explain in one line each the various types of charts. 
Types of charts 
	Types 
	Purpose 

	Column Chart 
	Comparing classes of data items in group. 
Group comparison 

	Bar Chart 
	Comparing classes of data items in group. 
Group comparison 

	Line Chart 
	Comparing classes of data items in group. 
Group comparison 

	Pie Chart 
	Comparing classes of data items as percentage. 

	XY Scatter Chart 
	Comparing data in pairs 



19. Write the steps to insert a chart in Calc. 


Follow the steps given below to create charts. 
• Select the range of data
· Insert → Chart 
• Select the type of chart 
· Click finish. A chart will be displayed. 
 

20. Name and explain any five components of a chart in a spreadsheet package. 
The different components of charts are as follows:

1) Chart area: This is the area where the chart is inserted.

2) Data series: This comprises of the various series which are present in a chart i.e., the row and column of numbers present.

3) Axes: There are two axes present in a chart. They are the x- axis and y- axis.

4)Plot area: The main area of the chart is the plot area.

5) Grid lines: They provide reference for the chart.

21. Can you include more than one mathematical operators in a formula? 

Ans More than one mathematical operator can be included in the formula. 
The order of evaluation can be changed by using brackets. (The expressions within the brackets are evaluated first).

22. Give examples of Spreadsheet Softwares?
Ans: Spreadsheet Softwares • Microsoft Excel • LibreOffice Calc • OpenOfficeCalc • Apple Inc. Numbers

23. What is Fill Handle tool?
The Calc Fill Handle tool is used to fill the next cells till you drag it with the next predefined value. For example, if you want to fill the numbers in sequence of 1,2,3...., or days of the week as Monday, Tuesday, ...., or month name as Jan, Feb,...., enter the first two values, select them and drag to the next cells till you wish to continue the series in sequence



